Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Negative switching or conduction losses are cropped

0 votes
46 views
Hi,

I have problems simulating thermal performance for two SiC-MosFETS from WOLFSPEED C2M0080170P and c3m0065090d. I have defined the performance for positive and negative currents, voltages and temperatures. Still this error is popping up. Did I do something wrong with the thermal description?? See attached.
asked Sep 13 by rubzi (12 points)

1 Answer

0 votes
Hello,

It appears that these are not the official thermal descriptions provided by the manufacturer on their website. We would recommend that you use those models if possible.

It is also not easy to fully diagnose the issue without having your circuit model that shows the error message. I suspect, however, the issue is a numerical one. For example, with the thermal description you attached for C2M0080170P, the Conduction Loss current axis has a value of 6.133300000000001e-15. You should change this to 0. Also, the datapoint at 25C and 10A is 0.8436100000000001. This should probably be truncated to 0.84361. Further, your thermal impedance coefficients have a complexity that may lead to a numerically stiff system.

Let me know if this helps.

Kris
answered Sep 13 by Kris Eberle (616 points)

Hello Kris, Thanks for your reply. 

I have changed what you pointed out above (the 6e-15 was an error - obviously should be zero). But this does not solve my issue. It seems my error is with C3x description, because if I don't attach any thermal description to this part my circuit runs fine. I have attached my model. The error is 

Negative loss values for component 3LNPP_SiC_wo_diodes/INVERTER/FETD3.
Negative switching or conduction losses are cropped

The same goes for FETD4. 

Looking forward to your reply. 
 

Hello,

Again, this is a numerical issue due to small roundoff errors created by not fully forcing the positive/negative conduction inflection point to be at zero current/zero voltage. Please change the 0A column voltage values for the conduction losses to all be 0V.

Thanks,

Kris
You are right Kris,

 

It works. Thanks for all your help :)
...