Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Implementation error: No port for terminal

0 votes
124 views
Hi,

I am running a MATLAB simulation with PLECS Blockset. In my PLECS Blockset, there is a grid model embedded inside a subsystem. Using Signal inport and signal outport, i am feeding in and taking the signals from the system. I am getting this unusual error which doesn't point to any port or terminal. I have attached the screenshots and simulation model to this question. Your response awaited.

Thanks

Shahbaz Hasan
asked May 12 by Hasan8 (12 points)
Hi Hasan,

Would it be possible to attach the initialization commands file --"SAPF_MPC_capload_parameter" so that I can try and simulate the circuit?

Regards,
Manu
Hi Manu,

Thanks for the prompt response. I have attached the script you can run the script to update the workspace for initial commands.

Regards,

Shahbaz Hasan
Hi Shahbaz,

This could be a bug.  I will get back with a definitive answer tomorrow.

Regards,
Manu

1 Answer

0 votes
Hi Shahbaz,

This is indeed a bug. The developers suggested the following workaround--
"To fix the Circuit block, you need to copy the complete schematic into a fresh Circuit block (and then you need to also copy all simulation parameters)."

Regards,
Manu
answered May 13 by Manu Parimi (243 points)
Hi Manu,

I will try this workaround and will get back to you with the status.

Thanks and Regards

Shahbaz Hasan
Hi Manu

Error got solved. It was a bug.

Thanks and Regards

Shahbaz Hasan
...