Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

PLECS executable cannot be started. Why?

0 votes
79 views

Hello, i am running a Simulink(Plecs Blockset) Simulation on a HPC Compute cluster and on the frontend it runs fine, however if i submit it to the compute nodes with a batch script it crashes. 

This is the output when i load a a Simulink Model containing a plecs block, or just run "plecs('version')" in the Matlab command line: 

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, offscreen_plexim, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, webgl, xcb.

Loaded PLECS module Version 4.4.3
Warning: Editor did not receive quit command. Killing the process.
Error while starting server: PLECS executable cannot be started.

 

Does anyone have an Idea where to start troubleshooting? 

 

asked Aug 21 by Hannes (29 points)

Where is was unsuccessfull so far:

  • Fixed all dependencies xcb needs, so it has the paths to all Libraries. -> error Still there
  • tried using ofscreen_plecs wich sounds its made for the job:
  • deleted the xcb file -> plecs still wants to load xcb
  • set "export QT_QPA_PLATFORM=offscreen_plexim" -> gets idnored, plecs still wants to load xcb
  • set the Display to "export DISPLAY=:0" -> still says "qt.qpa.xcb: could not connect to Display"

If you have any Idea, on what i could try or where the error could be or need some log files, please don't hesitate.

EDIT: X11 is not available on the system.

1 Answer

0 votes
 
Best answer

Xvfb was available on the System, so i created a new virtual Display for each Node using:

Xvfb :1 &

export DISPLAY=:1

That solved the Issue, though it would still be nice to run plecs(Qt) completely headless.

answered Aug 27 by Hannes (29 points)
...