Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

The internal oscillator cannot be greater than 194 MHz, which is different from that of tutorial video

0 votes
24 views

Error(s) during execution of code generation method 'Finalize' in 28379_test_Sep_4_dac_v3/Controller:

Excessive system clock setting for internal oscillator. Must not be greater than 194 MHz.

Below is the screenshot of tutorial video,in which system clock can be set as 200MHZ

Below is my own screenshot ,in which the error occurs.

So maybe it's a problem of plecs version or what???

asked Sep 4 by shichenseu (136 points)

2 Answers

0 votes
Maybe 190MHZ is perfect enough,because the oscillator frequency is 10MHZ.
answered Sep 4 by shichenseu (136 points)
0 votes

The maximum frequency of the 28379D when using the internal oscillator is 194 MHz.  The 200 MHz limit is if you are using an external oscillator circuit, which is not available on unmodified LaunchPad boards.  Refer to note (2) in this section of the 28379D datasheet.

The video was published before the TSP was updated to reflect this limit.

answered Sep 4 by Bryan Lieblick (213 points)
Thank U  so much ,I cannot express my gratitudes!!!
...