Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Error: Cyclic behavior during switching

0 votes
39 views
Hi Everyone,

I am getting an error "Cyclic behavior during switching" while trying to run the simulation attached.

 

Tried different solutions as said in the attached paper.

 

Could anyone help me correct the simulation file.

 

Regards,

Silpa
asked Dec 17, 2020 by Silpa (14 points)
edited Dec 17, 2020 by Silpa
Hello, I don't see an attachment, but did you perhaps refer to our website (https://www.plexim.com/support/solutions/146) about this topic? If that doesn't help you would need to attach your model file for anyone to help further.
Hi Kris,

Please find the attachment below.

I tried all the solutions provided in the above link.

Regards
Silpa

1 Answer

0 votes
Hi again. This is actually a simple issue. You have defined the series inductance values in your line input filter as "1*e-6", which is actually the equivalent to: 1 times the mathematical constant e (2.71828) minus 6 (resulting in a negative value). In PLECS, the syntax is "1e-6". You need to remove the * symbol in the assignments and then the model runs.
answered Dec 18, 2020 by Kris Eberle (1,054 points)

 

Hi again,

Thank you very much Kris for the valuable feedback :).

Yes, your solution rectified my error. Tons of thanks!!!

Regards,

Silpa

...