Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

PLECS Blockset error when using electrical ports

0 votes
259 views

Hi,

I am a new user of PLECS blockset and was familiarising myself with the components used to interface between Simulink and PLECS blockset. I was trying to use the electrical port block to connect simulink and PLECS blocks together as shown in the attached screenshot.

In the PLECS circuit, I only used the DC voltage source to act as a source and then used electrical ports to have the load simulated using Simulink blocks. For the load, I used a series RLC branch with just R=20ohms and connected a voltage measurement and scope across is to measure the voltage across the resistor.

However, when I try to run the simulation, I get an error saying "The model 'untitled' can't be solved, since it contains no state variables and no inputs.".

I have tried simulating the resistive load in just the PLECS circuit and it runs just fine but I would like to learn to make electrical connections between Simulink and PLECS circuits. Can someone please tell me what I am doing wrong here?

Many thanks in advance for your help and time!

asked Apr 7, 2023 by New_user (37 points)

1 Answer

0 votes
 
Best answer
Hello,

Actually it is not possible to connect PLECS directly with Simscape components. You will need to interface physical systems via control/signal blocks in the respective tools, such as for taking measurements and controlling sources. See also here: https://forum.plexim.com/281/how-can-i-link-plecs-inverter-with-simulink-load.

Regards,

Kris
answered Apr 10, 2023 by Kris Eberle (1,595 points)
selected Apr 10, 2023 by New_user
...