Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Turn off Loss in LLC

+1 vote
156 views
Hi, I have a question regarding to the turn off loss using thermal model.

When I run LLC at lower than resonant frequency, I have the problem of no turn off loss. (no turn on loss either but this is expected since it has zero voltage switching). But when I change it to higher than resonant frequency, the turn off loss appears.

Can some one help me with this problem?

Thank you.
asked Apr 27 by chinaren007 (17 points)
Please provide your model and your thermal data sheet.
Hi Oliver,

     The model is attached along with the init function.

      I use the default thermal model of IPW60R280P6, which is provided by PLECS.

Thank you.

Bin

1 Answer

+2 votes
 
Best answer
I can only repodruce this problem if I set a refine factor > 1. From first sight it seems to be a display problem in PLECS blockset. The losses, however, are calculated correctly as can be seen by the output from the Periodic Impulse Average block (or by observing the heatsink temperature). We'll look into this.

What version of Matlab are you using?
answered Apr 27 by Oliver Schwartz (147 points)
selected Apr 29 by chinaren007
Thank you for the response.

My MATLAB information is below:

MATLAB Version: 9.0.0.341360 (R2016a)

Operating System: Microsoft Windows 10 Enterprise Version 10.0 (Build 15063)
Java Version: Java 1.7.0_60-b19 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode

Can I change the refine factor?

Thank you.
Sure. In the Simulink Model, choose the menu entry "Simulation" / "Model Configuration Parameters", then open the "Data Import/Export" tab. The "Refine factor" parameter is in the lower half of the dialog. In newer versions of Simulink you have to expand the "Additional parameters" in the lower part of the dialog to see it.

The refine factor smoothes the output curve by calculating additional curve value based on higher-order interpolation. This is more efficient than reducing the simulation step size but does not necessarily give correct values between the "real" simulation steps.
It is really great!

Thank you very much. Now I have the correct waveform with turn off loss.

Thanks Oliver!
...