Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Is it possible to deactivate the extrapolation in 1D-Table?

0 votes
23 views

Greetings,

while trying to understand the File Importing function from this thread: https://forum.plexim.com/11/is-it-possible-to-import-waveform-data-into-plecs It was found out that, when the datas in .CSV files "run out", the 1D-Table Block will automatically extrapolate the rest of data until end of simulation. This makes it hard to achieve a automatically adjusted simulation time by getting a warning signal, when the data stream has depleted itself during simulation.

Quesion: Any work around for this? Either disable Extrapolation or other form of stopping the simulation (Not aborting) will definitely help.

Thanks.

asked Aug 28 by Lapata (12 points)

1 Answer

0 votes

The From File component, introduced in PLECS 4.4, has an Output after last time step parameter where you can specify: linear extrapolation, hold last value, or specify last value.

If you want to keep using the old method of importing data, you could add a dummy time step / value pair just after the last pair in your series.  That way the result of the extrapolation is a constant value.  Another "lazy" workaround is to add a Saturation block.

 

 

 

answered Aug 28 by Bryan Lieblick (213 points)
...