Please take a minute to review and accept our Terms of Use.
Welcome to the PLECS User Forum, where you can ask questions and receive answers from other members of the community.

Many technical questions regarding PLECS are answered on the Technical Solutions page of our website. Tutorial videos, specific application examples, and pre-recorded webinars are available on our YouTube page. Please follow us on LinkedIn for the latest Plexim news.

Is there a 100 ms delay during turn on in the C2000 powerstage protection block?

0 votes
46 views
I noticed that my gating signals take 100ms to turn on after I enable the C2000 powerstage protection block (low to high transition on the "en" input) in an F28379D DSP. However, when I turn off the block, gating seems to stop immediately? Is there a 100ms turn on delay built into this block? This 100ms delay causes the integrator in my PI block to accumulate error during this period causing a current spike during turn on. I can probably prevent this by keeping the integrator in reset mode until the 100ms has elapsed. But I need to know for sure if the delay was caused by the powerstage protection block or due to some delay in my hardware.
asked Jul 6 by Chatumal (14 points)

1 Answer

0 votes
There is ~100 msec delay between when the Powerstage Protection block's input changes and when the PWM's activate.  Note that the output signal of the Powerstage Protection will incorporate this delay as well, so using the block's output signal in your anti-windup scheme instead of the input signal to the block may resolve your issue.
answered Jul 7 by Bryan Lieblick (1,187 points)
...